<< return to Pixycam.com

Pi3 complains about too much power draw


I recently picked up a new pixy2 to play with.
when I hook it up to a PI3 via usb it complains about over current and
the pixy2 device is freaking out. The spec sheet says only a few hundred mA
nothing near the usb limit. which on the pi3 with nothing else plugged in is 1.2A

When I plug the thing into my normal desktop machine I get things working ok
[4077153.731001] usb 3-12: new high-speed USB device number 87 using xhci_hcd
[4077153.859621] usb 3-12: New USB device found, idVendor=b1ac, idProduct=f000
[4077153.859626] usb 3-12: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[4077153.859629] usb 3-12: Product: Pixy
[4077153.859632] usb 3-12: Manufacturer: Charmed Labs
[4077153.859635] usb 3-12: SerialNumber: DEMO 0.0

and the device resets and centers itself nicely.





Hi Steve,
Hmm, I’ve never seen a Pixy draw more than 150mA. I’m not sure if the problem is with your Pixy2 or your Raspberry Pi. I wouldn’t think the current capabilities of the Raspberry Pi USB are much different than your desktop. How are you powering your Raspberry Pi?



Do you have servos running over USB? That usually doesn’t work.


yeah it does seem that its the pan/tilt units that are drawing more then the USB port can handle.
if I connect the USB and power into the IO port on the pixy from a gpio pin that does work.
life is good.


Nice catch Olli!

The servos can sink about 500mA each worst case (stalled). It can be an issue, but it’s not common. Is your pan-tilt a little tight mechanically speaking?



it seems to be free enough. the pixymon pan/tilt demo however seems to not do much.
nothing moves and I just get the occasional voltage stabilized message in the pi system logs.
it might be too much power even for the 5v rail on the PI. will have to try
a non-pi related power source and see if that changes things.
the video on it works in the pixymon program. so at least its mostly working.



Hi Steve,
Some more questions. Are you using the USB cable that came with your Pixy2? When running the pan/tilt demo, do you see video in PixyMon?

You might also set the default program to pan-tilt demo. You can set in the expert config tab.


You can then try just plugging into a random computer with a USB port and Pixy will startup with the pan-tilt demo.



Ive tried the cable that came with the unit, Ive tried other usb cables to my desktop machine
even usb power adapters straight into the unit.
Video does work just fine as well as the line demo connected to both a pi and my desktop machine.
the pan/tilt demo stops showing video but doesnt move the unit anywhere.
When it starts any of the demo programs the unit moves itself to looking straight ahead and keeps
it there. there is generally no torque on the motors but if I try to move the unit it keeps it in place.
unplugging either of the motors doesnt change anything. in case one was drawing too much power.



Hi Steve,
Let me try to summarize. Correct me if I’m wrong. You can’t get the pan-tilt demo to work regardless of the power source – USB power via Raspberry Pi, USB power via PC. You are connecting directly to the USB port, not using a USB hub. You are using the Pixy2 pan-tilt unit , not a different mechanism.

If you haven’t done so already, please set up the pan-tilt demo as the default program (described in my previous message). Then try plugging Pixy2 into a different computer’s USB port. Pixy2 will boot into the pan-tilt demo and you can easily check the demo using whatever USB port you plug into (and not needing to install PixyMon on that computer to run the demo).



that is all correct yes. I have tried it plugged into a powered USB hub as well. The results are always the same.
The pan/tilt is the default startup program. If I start the pixymon on a computer (pi/desktop never windows though) it does say its running the pan/tilt demo. but the only movement it does is to recenter itself on power up from where ever I have moved the servos to with the power off. and then tries holds the servos there if I try to move them again.
is it possible to reflash the pixy2 board?




Hi Steve,
We’ll follow up via email to try to get this resolved.