<< return to Pixycam.com

pan/tilt servo malfunction


I recently purchased a pixy and pan/tilt kit but I am having issues with it. The servos go crazy out of control when I try to run the demo from pixymon, also the same case when running it from Arduino. I was using a very short cable of about 1ft long and then I changed to a longer cable of about 3ft and the problem still remains. I have also tried many solutions listed in the forum but nothing helps.

Please help me out on this as soon as possible because I am using pixy for my university project and I need to come up with a solution.



Hello Shoaib,
Make sure you’re not using a USB hub, or perhaps your servo wires are reversed. Have you seen this guide?


Also make sure that your Pixy has a good lock on the object you are trying to detect.




My servos pan/tilt to max position, then sit there jittering.

I tried adjusting frequency (default is 60) and reducing range (default is -200 - +200).

I connected 2 similar 9oz servos and they worked correctly with freq = 75.

Any suggestions as to adjusting settings or other fixes for the original servos? Different manufacturers’ servos might need different settings?

Any help is appreciated.


Hi Tony,

sounds like a power issue. How are you powering Pixy and Pan/Tilt?



I have similar symptoms.
Keep loosing track of the object. Inconsistent servo movement buzzing jittering etc…

Powering it with a good straight short usb cable.
I want to hook up a power cable on that white connector, but i dont know what the polarity should be.
Is it -+ Or ± left to right?


Hi Peter,
Are you using the servomotors on the right (see pictures in the link below)?


If so, it will probably require some tuning of the PID parameters.

Here is some information on powering over the power connector:


I was reading your other issues, the clicking and the like, and I’m wondering if your servos are somehow defective. Let me know what you find with the other power source.



Hi…the first thing that’s struck me is that it looks like the servo’s have not been bolted to the mounting hardware in an exactly central position. Servo’s have a physical stop “bumper” which it sounds like your hitting on at least one of the servo’s. The only way to fix this would be to find the central point of the servo (I would probably do this by estimation), then unbolt the servo from the hardware and re-bolt it back on in the correct position.