<< return to Pixycam.com

Error: no response in the function pixy.init(). (Pixy2)


#1

hey guys,
recently our team got a Pixy 2. we had the first version and it worked great.
Im trying to connect the pixy to arduino and i followed this tutorial and when i run the ccc_hello_world the message error:no response is showing in the serial monitor
pixy2problem


#2

Hi,

please make sure your Pixy2 is running the ccc (color connected components) program from PixyMon, and that you have taught it an object as described here: https://docs.pixycam.com/wiki/doku.php?id=wiki:v2:teach_pixy_an_object_2

Hope this helps!

Cheers,
Jesse


#3

i can still see the message: " error : no response" i did make sure that i ran the ccc program and i also checked that the pixy can detect objects but the problem is still exist.


#4

Sorry you’re still having trouble. What model of Arduino are you using? Have you tried reversing the cable where it plugs in to Arduino?

Could you post a photo of your setup? This will help us diagnose the issue.

Thanks,
Jesse


#5

Hi, im using the Arduino Uno model, i dont think the problem is with the cable because i can see other prints that i do in the Serial monitor.
here are some pictures of the setup i have
20190123_17083320190123_170819


#6

Hello,
Sorry for the problems and thanks for the pictures. Here are a couple other things to check.

Is Pixy2’s LED illuminated, indicating that it has detected an object when the object is in Pixy2’s frame?

Is the “Data out port” parameter set to “Arduino ICSP SPI”? (it should be)

https://docs.pixycam.com/wiki/doku.php?id=wiki:v2:pixymon_index#interface-tab

Edward


#7

Yes the LED is illuminated, and i can see that the pixy detects the objects with the windows software, and the data out port is set to Arduino ICSP SPI.


#8

Hmm, the only other thing I can think of is either there is an issue with your Pixy2 hardware or an issue with your Arduino Uno hardware. Do you happen to have another Pixy2 or another Uno you can swap out to narrow down the problem?

Edward


#9

I do have 2 pixies i tried both of them and the problem still appears. Maybe there is a problem with the library?


#10

Maybe ill try to re-install the arduino IDE. But i can try it only tommarrow


#11

If both Pixys are refusing to communicate with the Arduino, I would start to suspect the Arduino. If there is another Arduino you can try, that would be a good thing to try. Let me know what you find.

Edward


#12

Well, both pixys didn’t respond, right now im trying to get another arduino.


#13

Problem Solved!. it was the Arduino that was broken i tried using other Arduino and it ran just right.
thanks for the help


#14

That’s good news! :slight_smile: